Last Reviewed: March 18, 2002

Article: DTS0107

Applies to: dtSearch (all versions)

Symptoms

When an Access database file is indexed, dtSearch treats it as one long text file instead of as multiple records.

Possible Cause

ODBC drivers are not installed.

dtSearch indexes, searches and displays Access files using Microsoft OCBC drivers. If the ODBC drivers are installed, dtSearch should index a database file as a series of records. The name of each record includes the filename of the database, the name of the table, and a record identifier. If instead dtSearch indexes a database as a single text file, you probably do not have the ODBC drivers installed.

Resolution

If you have Office 97, Office 2000, or Office XP, reinstall it with the option to install "Data access" components selected.

If you do not have Microsoft Office or another source of the ODBC drivers, you can download them from the Microsoft web site. Two separate downloads are required:

(1) The Microsoft Data Access Components (MDAC), available here:

     http://www.microsoft.com/data.

(2) The Microsoft "Jet" database engine, available here:

     http://support.microsoft.com/default.aspx?scid=kb;en-us;Q239114&id=Q239114

Note: Even with both of the above installed, some users have reported that ODBC still did not work until Microsoft Office was also installed. It may not be possible to use ODBC to access desktop databases without installing Microsoft Office.

For more information on installing MDAC and the Jet Engine, please see these articles on the Microsoft web site:

     MDAC Installation

     HOWTO: MDAC Setup Troubleshooting Guide (Q232060)